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Class Administrator© License Agreement 

IMPORTANT-READ CAREFULLY: This LICENSE AGREEMENT is a legal agreement between you 
(either an individual or a single entity) and EduConnect, Inc. for the SOFTWARE PRODUCT identified 
above, which includes computer software and may include associated media, printed materials, and 
"online" or electronic documentation. By installing, copying, or otherwise using the SOFTWARE 
PRODUCT, you agree to be bound by the terms of this License Agreement. If you do not agree to the 
terms of this License Agreement, do not install or use the SOFTWARE PRODUCT. 
 
SOFTWARE PRODUCT LICENSE 
 
The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as 
other intellectual property laws and treaties. The SOFTWARE PRODUCT is licensed, not sold. 
 
1. GRANT OF LICENSE. You may install and use the SOFTWARE PRODUCT on a standalone computer 
at school and one other copy on the teacher's computer at home. You may not reproduce or distribute 
copies of this SOFTWARE PRODUCT for use at any other buildings or sites. The SOFTWARE 
PRODUCT is licensed as a single product. Its component parts may not be separated for use on more 
than one Local Area Network. If this is a Trial Version, you may only use this SOFTWARE PRODUCT for 
the length of the trial and, if you decide not to purchase the Registered Version, you must delete this 
SOFTWARE PRODUCT from your computer. 
 
2. COPYRIGHT. All title and copyrights in and to the SOFTWARE PRODUCT (including but not limited to 
any images, photographs, animations, video, audio, music, text, and "applets" incorporated into the 
SOFTWARE PRODUCT), the accompanying printed materials, and any copies of the SOFTWARE 
PRODUCT are owned by EduConnect, Inc. The SOFTWARE PRODUCT is protected by copyright laws 
and international treaty provisions. Therefore, you must treat the SOFTWARE PRODUCT like any other 
copyrighted material except that you may install the SOFTWARE PRODUCT on a Local Area Network 
provided you keep the original solely for backup or archival purposes. 
 
3. This LICENSE AGREEMENT is governed by the laws of the State of Kansas.  
 
4. DISCLAIMER OF WARRANTY. EduConnect, Inc. expressly disclaims any warranty for the 
SOFTWARE PRODUCT. The SOFTWARE PRODUCT, accompanying files and any related 
documentation is provided "as is" without warranty of any kind, either express or implied, including, 
without limitation, the implied warranties or merchantability, fitness for a particular purpose, or 
noninfringement. The entire risk arising out of use or performance of the SOFTWARE PRODUCT remains 
with you. 
 
5. NO LIABILITY FOR DAMAGES. In no event shall EduConnect, Inc. or its suppliers be liable for any 
damages whatsoever (including, without limitation, damages for loss of business profits, business 
interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability 
to use this SOFTWARE PRODUCT. THE LIABILITY OF THE SELLER WILL BE LIMITED EXCLUSIVELY 
TO PRODUCT REPLACEMENT OR REFUND OF PURCHASE PRICE.  
 
 
 
 
 
 
 
 
 
 
 
 



 3

Program Setup 

 

Class Administrator requires Microsoft Excel 2000 or later for Windows computers or Microsoft Excel 
2001or later for Macintosh computers. The program is installed by default in the Program Files\Class 
Administrator directory for Windows or the Hard Drive:Class Administrator directory for Macintosh. The 
program files must not be moved from this directory. The following files are installed.  

• ClassAdmin.xlt: This file is a template that is used to create new gradebooks or to open existing 
gradebooks and should be used to start the program. It should appear as an icon on the desktop.  

• ClassAdmin.xla: This file is an addin for Excel that contains most of the program code for the 
letter/percentage gradebooks. The addin is protected by a password and cannot by viewed by 
users.  

• ClassAdminOutcome.xla: This file is an addin for Excel that contains most of the program code 
for the outcomes gradebooks. The addin is protected by a password and cannot by viewed by 
users.  

The Macro Security in Microsoft Excel must be set to Medium before running the Class Administrator 
program.  Open a blank workbook in Excel,  then go to the Tools, Macro, Security menu choice to set this 
option. 

For Macintosh computers, the memory allocated for Excel should be increased. To increase the memory, 
click on the Microsoft Excel program file in the Microsoft folder, then go to File, Get Info in the Macintosh 
menu bar. Click on the memory choice and increase the Preferred Size to 15000 K and the Minimum Size 
to 12000 K.  

To open the program on Windows computers, click on the Class Administrator icon on the desktop. To 
open the program on Macintosh computers, browse to the Class Administrator folder on the Hard Drive 
and open the ClassAdmin.xlt file. 
 
When a new gradebook is created, it is automatically saved to the default directory. Gradebooks can also 
be saved to other directories or to a removable disk. Existing Gradebooks can be opened through the 
Program icon on the desktop, or from the Recent Files selection in Microsoft Excel's File menu, or by 
browsing to the Class Administrator folder in the Program Files directory. Gradebooks can be used on 
any program on which the Class Administrator program is installed. See Saving Gradebooks for more 
information on this topic. 
 
When a gradebook is opened, the Class Administrator program will replace the normal Excel menu with a 
customized menu for use with this program. Most of the normal popup windows that are accessed by 
right clicking with the mouse are also disabled. This is done to prevent the user from inadvertently making 
changes that would cause problems with how the program reads data from the spreadsheet. The Class 
Administrator menus should be used to make any needed changes. Once you exit the gradebook, the 
normal Excel menu will be restored. 
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Getting Started 

To create a new gradebook, click on the Class Administrator icon on the desktop(for Windows computer), 
or open the ClassAdmin.xlt file in the Class Administrator folder. You can choose to create either a 
standard Letter/Percentage gradebook or an Outcomes Based gradebook. 
 
Once you have created a new gradebook, you should enter the course information. If you are using Class 
Administrator with the School Administrator program, the class/subject name, section, grade level and 
teacher name should be identical to those items as entered in the School Administrator program. 
 
After entering the course information, you should set up the Grading Information for the Letter Report 
Cards or the Outcomes Codes for the Outcomes Report Cards. 
 

Enter Course Info 

Each time a new class is added, the Enter Course Info form will appear. The information that can be 
entered for each class includes  

• Class Name;  

• Class Section: Enter 0 unless more than one class of the same subject at the grade level is 
offered. If more than one class of the same subject is offered at the same grade level, then 
identify each by a different section integer.  

• Grade Level for the class;  

• Teacher's Name for the class.  

If this program will be used with the School Administrator program to create Report Cards, the 
class name, section, grade level and teacher's name must be identical to that entered in the 
School Administrator program. 
 
 

Add/Delete Classes or Subjects 

The first class in the gradebook is automatically added when the gradebook is created. Additional 
class/subject worksheets can be added to the gradebook for each subject taught from the Add New 
Class/Subject command in the Class Info menu or from the Add Class/Subject button in the toolbar. The 
name of the class worksheet is determined by completing the Enter Class Information form. 

You can also delete classes using the Add/Delete command in the Class Info menu. Class Worksheets 
can also be deleted by right-clicking the class name tab at the bottom of the Excel window. 
 

Add/Change/Delete Students 

Students can be added to the class by importing them from the School Administrator program, by 
entering them one at a time using the Add New Student menu command or button, or by entering them 
directly into the cells of the class worksheet. Importing the students from the School Administrator will add 
the new students to any previously entered. The students will be automatically sorted in ascending order 
if imported from the School Administrator program. 

To import students from the School Administrator program, it is necessary to login to School Administrator 
and view the class list for the class created in the Class Administrator gradebook. Select the Student ID, 
Student Name (Last Name first), Phone Number and Parents to view. When the list is shown, drag the 
mouse across the data while holding down the left button. Once all of the information is highlighted, place 
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the cursor somewhere in the highlighted area, right click and choose Copy from the popup menu. Then 
follow the instructions in the Import Students Wizard to complete the import process. 

The default settings in the Class Administrator gradebook only show the Student Name and Student ID 
columns. To view the Phone Number and Parent Names columns, use the Student Info menu command 
in the View Menu. Information can be changed for a student by using the Change Student Info command 
or entering the changes directly in the class worksheet cells. 

To delete a student, use the Delete Student menu command. Do not delete a student by selecting the 
cells that contains the student and using the Delete key on the keyboard. 
 

Enter Class and Student Comments 

Class Comments  

Class comments can be imported from School Administrator or entered manually. If you will be publishing 
final grades to School Administrator for Report Cards, the class comments and their codes entered in the 
Class Administrator gradebook must match the comments and codes in the School Administrator 
program. 

To import class comments from School Administrator, first login to the School Administrator program, go 
to the Report Card module, and click on View Comments. Highlight the comments and their codes by 
dragging the mouse across them while holding down the left button. Once all of the comments and their 
codes are highlighted, place the cursor somewhere in the highlighted area, click the right button of the 
mouse and choose Copy from the popup menu. Then go to the Import Comments command in Class 
Administrator and follow the instructions of the Import Comments Wizard. Importing comments from 
School Administrator will delete any previously entered comments. 

To enter comments manually, go to the Add/Change/Delete Comments command in the Class Info Menu 
and enter in the comments desired. A numerical code will be assigned automatically to each comment 
entered. Comments can be changed or deleted using the same form. 

Student Comments 

To enter student comments, go to the Enter Student Comments command in the Class Info Menu. Two 
comment codes may be entered for each student. Comments that correspond to the code entered will be 
displayed in the Student Single Class Summary and the Student Multi Class Summary reports. The 
comments will also be displayed in the Report Cards in the School Administrator Program when grades 
are exported to that program or on the Report Card workbook if grades are exported to it. 
 

Exporting Grades 

Grades can be exported to EduConnect's School Administrator program, to a Report Card workbook that 
is included with the Class Administrator program, or to a comma delimited text file by using the Export 
Grades command in the Tools menu.  

The report cards in the School Administrator or in the Report Card workbook can be customized for 
individual schools. Contact EduConnect for more information on customizing the School Administrator 
report card or the Report Card workbook. 

Exporting to School Administrator 

When exporting grades to the School Administrator program, you need to know the name of the computer 
from which the School Administrator program is accessed. The name of that computer is identified at the 
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School Administrator login page before the slash that precedes SchoolAdmin in the address bar of the 
web browser. For example, if the address is http://server/SchoolAdmin, the name of the host computer is 
server. The Export Grades to School Administrator task will publish the grades to an html file, which then 
is opened in your web browser. This task may take some time, so be patient and wait for it to be 
completed. Once the html file is opened in the web browser, click the Submit Grades button to submit the 
grades to the School Administrator program. 

Exporting to Report Card Workbook 

Grades can also be exported to the Report Card workbooks that are included with the Class Administrator 
program. Before grades can be exported to the Report Card workbook, you need to configure a master 
report card and individual student report cards for each grade level. The installation file for the Report 
Card workbooks is named ReportCardInstall and is located in the Class Administrator folder. To install the 
Report Card Workbooks, open the ReportCardInstall file and click on the Unzip button. The default 
installation directory for the Report Card files is Report Cards. To configure the master report card, 
browse to the Report Card folder and open the appropriate Report Card type. Then read the Report Card 
User Guide for information on how to set up the master Report Cards for each grade level. 

It is best to set up the Report Card files on a network server so all teachers have access to the Report 
Card workbook. If there is not a school wide network with a server available, then the grade level report 
cards would need to be saved to a computer to which all teachers of that grade level have access, or 
saved to a floppy or other external disk that could be shared with the appropriate teachers. For 
information on this topic, open the Report Card workbook and read its User Guide. 

Exporting to Text file  

Copying grades to a comma delimited text file make it possible to transfer the grades to other 
administrative programs. The text file is saved in the Program Files/Class Administrator directory. Only 
the Letter Grade report cards can be exported to a text file.  

Saving Gradebooks and using them on multiple Computers 

Each time you create a new gradebook, you will be prompted where to save the gradebook. If your school 
has a server, it is recommended that the gradebooks be saved to a shared folder on the server. This will 
allow the gradebooks to be accessed by an administrator, if needed. It will also make it easier to backup 
the gradebooks for all teachers. In addition, student multi-class progress reports can be produced from 
multiple gradebooks if they can be opened simultaneously.  

If no server is available, then the gradebook can be saved to the local computer. It is important that a 
backup copy of the gradebook be saved to prevent loss of data if the computer crashes. 

It is likely that a gradebook will eventually exceed the capacity of a floppy disk when multiple classes and 
numerous grades are entered. Therefore, gradebooks need to be saved to a memory stick or flash drive 
to back them up or to take them between school and home. If you wish to use a copy of the gradebook on 
your home computer, you must install the Class Administrator program on that computer. 
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Letter Gradebooks 

Enter Letter Grading Info 

Using the Enter Grading Info Command in the Class Info menu of the Letter Gradebook opens a form 
with the following pages. Information should be filled in for all of the pages before closing the form. 

General Page 

The following information is entered on the General page. 

• Identify how the term and final grades will be shown, either as letter grades or as percentages. To 
use letter grades, the grade scale must be entered in the Grade Scale page.  

• Identify how term and final grades will be calculated. There are four choices for calculating 
grades.  

1. Using total points for both term grades and final grades. This choice divides the total 
points earned by the total points possible for each term and for the final grade calculation.  

2. Using weighted categories for each term grade and for the final grade. This choice takes 
the sum of the average score for each category times the categories weight divided by 
the sum of the weights to determine the grade for each term and the final grade. For 
example, if there are three categories named Homework, Quizzes and Tests with 
respective weights of .3, .3 and .4, the calculation for each Term grade would be: 
(Homework Assignments Average * .3) + (Quiz Assignments Average * .3) + (Test 
Assignments Average * .4)/(.3 + .3 + .4). The average for each category can be 
determined by using the percentage score of each assignment in that category or by 
taking the total points earned divided by the total points assigned for the category. The 
Final Grade would use the same calculation for the categories for all terms combined.  

3. Using total points for each term grade and term averages for the final grade. This choice 
computes the term grades the same as in choice 1, but then takes the averages of the 
term grades to calculate the final grade. Each term average is weighted equally when 
calculating the final grade.  

4. Using weighted categories for each term grade and term averages for the final grade. 
This choice computes the term grades the same as in choice 2, but then takes the 
averages of the term grades to calculate the final grade. Each term average is weighted 
equally when calculating the final grade.  

If the type of grade calculation is changed after student scores have been entered, the Term Grades and 
Final Grade will automatically be recalculated using the new type of grade calculation. 
 
Terms Page 
 
The following information is entered on the Terms page. 

• The terms during the school year covered by the class. You can choose among semester, 
trimester or full year classes. The Letter gradebook is formatted to record one final grade for the 
terms selected. In most cases, this grade will be for each semester or trimester. If only one final 
grade is given for the entire year, the Full year option should be selected when entering the 
Grading Information. To create classes for another semester or trimester, you can either enter 
new classes with different section numbers in the same gradebook, or you can create a new 
gradebook for the new semester or trimester. If you wish to create a new gradebook with the 
same students for each class, use the Create New Gradebook in the Tools menu to transfer 
information to the new gradebook.  

• Enter a weight for recording the Final Test as a separate term. This option is used if you wish to 
record a final test grade that is not part of any of the term grades. You must select grading option 
3 or 4 in the General tab to use this option. The term name for the Final Test is Final. If the final 
test is recorded as a separate term, then the weight for the final test should be entered here. 
Each of the terms covered by the class will then receive a weight equal to (1- final test 
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weight)/number of terms. For example, if the final test is given a weight of .2 and the class covers 
two terms, each of the terms would then receive a weight of (1-.2)/2 or .4. The final grade 
calculation would then be (Term 1 average * .4) + (Term 2 average * .4) * (Final Test Percentage 
* .2).  

Categories Page  
 
The names and weights for user defined categories is entered on the Categories page. If option 1 or 3 is 
chosen on the General Page, the entry of categories is optional.  If option 2 or 4 is chosen on the General 
Page, categories and their weights must be entered. Weights must be entered as a decimal and the total 
of the weights must equal 1.  
 
You can set up a category named Ungraded for any assignments that you don't want to include in the 
grade calculation. This will allow you to enter any text for those assignments. This category should have a 
blank weight if option 1 or 3 is chosen on the General page or a 0.0 weight if option 2 or 4 is chosen on 
the General page.  
 
Grade Scale Page  
 
The grade code and minimum percentage for each grade is entered on the Grade Scale page. A grade 
scale must be entered to assign letter grades to the term and final grade percentages. 
 

Add/Delete Assignments 

When a new class is created, one blank new assignment is shown. A unique assignment name should be 
entered in row A for that assignment. It is recommended you enter a short name for the assignment, so it 
can be viewed in it's entirety in the cell. If you need more information about the assignment, you can right 
click on the assignment name cell and a menu will pop up that will allow you to enter a comment for the 
assignment. After a comment is entered, it will appear anytime you place the mouse over the assignment 
name cell. 

Other information for the assignment that should be entered in the appropriate rows include: 

• the term for the assignment;  

• the category of the assignment, if categories were entered in the grading information;  

• the date the assignment is due;  

• the total number of points the assignment is worth.  

To add additional assignments, use the Add New Assignment command in the Class Info menu or the 
Add Assignments button in the toolbar. The information listed above should be entered for each 
assignment. Each assignment should be given a unique name. Important: Do not leave any blank 
assignment columns between assignments. 
Student grades are not calculated for an assignment until points earned on that assignment are entered 
for individual students. For more information on entering student points earned for an assignment, go to 
Entering Student Scores. 
 
To delete an assignment, use the Delete Assignment command in the Class Info menu. 
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Entering Student Scores 

Individual Assignment Scores  

Student scores for individual assignments can be entered as a whole number or as a decimal number. 
For example, a score of 10 should be entered as 10, a score of 10 

1
/2 should be entered as 10.5. Each 

time a student score is entered for an assignment, the student's Term Grade that includes that 
assignment and the Final Grade are recalculated to include the new score. 

Student scores can be entered directly into the cells of the worksheet. Scores can also be entered by 
right clicking on a student cell in the assignment column, then using the Enter Assignment Points 
command to enter scores for individual students or the Repeat Assignment Points to enter the same 
score for that assignment for all students in the popup menu. The popup menu will also allow you to 
change the format of the cells or to change the fill color of the cell.  

An assignment is not included in the Term and Final Grades calculations until a student score is entered. 
If an assignment point total is changed after student scores have been entered, Term and Final Grades 
will be recalculated for those students who have a score for that assignment. 

Special Student Scores  

• Blank scores will be included as a missing assignment when reports are generated, but will not 
be included in the grade calculation.  

• If you want to include the missing assignment in the grade calculation, an M should be entered. 
This will count as 0 points earned for the assignment.  

• If a student is exempt from an assignment, an X should be entered as the score. This will exclude 
the assignment from the grade calculation and also exclude it from the missing assignments list 
for that student.  

• If you want to record an assignment has been received but not yet graded, enter a score of NG. 
This will not count the assignment as part of the total score and not count it as missing.  

Using an Ungraded Category 
 
If you set up a category named Ungraded for any assignments that you don't want to include in the grade 
calculation, this will allow you to enter any text for those assignments. This category should have a blank 
weight if option 1 or 3 is chosen on the General page or a 0.0 weight if option 2 or 4 is chosen on the 
General page in the Enter Grading Info form in the Class Info menu. 
  
Manually Changing Term or Final Grades 
  
It is possible to manually change the term percentages and grades and the final percentages and grades 
if for some reason the student will receive a grade different than the calculated grade. Changing these 
items will not cause any automatic changes in other percentages or grades. If these items are 
inadvertently changed, you can reset the default values by using the Recalculate Grades command in the 
Tools menu. (Note: Any time you add additional grades, the program will recalculate the Term and 
Final Grades.) 
 

 

Enter Custom Codes 

Schools can enter other information relevant to their school, such as Conduct or Effort grades or 
Instructional Level or Work Habits information in the two columns set up for custom fields. This 
information can be set up in the School Administrator program when creating report cards or it can be 
setup in the Report Card workbook template. 
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To enter the codes in the custom codes columns, go to Custom Codes in the View menu. Enter the 
appropriate codes for each field in the columns provided. The order entered should match the order for 
the fields set up in the School Administrator program or in the Report Card workbook template. 
 

Letter Gradebook Tools Menu 

These tasks can be found in the Letter Gradebook Tools menu. 
 
Export Grades: See Exporting Grades  

Drop Lowest Score: This command will drop the lowest score for students. The lowest score can be 
identified by terms or by categories. 

Copy Assignments: This command allows the user to copy assignments from one class to another. This 
is useful if more than one class on the same subject is being taught at the same grade level. 

Copy Students: This command allows the user to copy students from one class to another in the 
gradebook. 

Copy Class Comments: This command allows the user to copy Class Comments from one class to 
another in the grade book. 

Copy Grading Info: This command allows the user to copy General Info, Term Info, Categories and the 
Grade Scale from one class to another in the grade book. 

Create New Gradebook: This command is used to create a gradebook for a new semester or trimester in 
the same year or to begin a new year. Grading Information and/or student lists can be copied to the new 
gradebook. The Create New Gradebook wizard guides the use through the process of creating the new 
gradebook. 

Set Password: This command allows the user to set a password to restrict access to the gradebook. 

Recalculate Grades: This command will recalculate individual student grades for all terms and the final 
grade. 

Protect\Unprotect Sheet: Sheets should only be unprotected if data is inadvertently written to a 
protected cell and needs to be corrected. 

Unhide Assignment Columns: This command will unhide any assignment columns that inadvertently 
become hidden. This can occur if the use forgets to enter a Term number for an assignment and then 
selects a term choice from the View Terms drop down menu.  

Reset Gradebook Menu: This command can be used if error messages occur when attempting to 
execute menu commands. Resetting the gradebook menu will frequently eliminate the problems causing 
the error messages. 
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Outcomes Gradebook 

Enter Grading Info for Outcomes Gradebooks 

The first tab in the Enter Grading Info window selects the terms for the gradebook. If semester or 
trimester grades are given for the outcomes, then select the appropriate semester or trimester option. If 
outcomes grades are only given for each term with or without a final grade at the end of the year, then 
Full Year should be chosen. 

The second tab enters the outcome codes and their descriptions. The outcome codes represent the 
grade that would be entered on the Report Card for a particular outcome. Each code should have a 
description of its meaning. If the grades will be exported to the School Administrator program, the codes 
in the gradebook should match the codes entered in the School Administrator program. 

Enter Subject Outcomes 

Outcomes for the subject can be imported from the School Administrator program or entered manually. 
Go to Enter Subject Outcomes in the Class Info menu to perform this task.  

To import subject outcomes from School Administrator, first login to the School Administrator program, go 
to the Report Card module, and click on View Grade Level Outcomes. Highlight the outcomes and their 
numbers by dragging the mouse across them while holding down the left button. Once all of the outcomes 
and their numbers are highlighted, place the cursor somewhere in the highlighted area, click the right 
button of the mouse and choose Copy from the popup menu. Then go to the Import Outcomes command 
in the Enter Subject Outcomes choice in the Class Info menu of Class Administrator and follow the 
instructions of the Import Outcomes Wizard. Importing outcomes from School Administrator will delete 
any previously entered comments. 

Outcomes can also be entered, changed or deleted manually by using the Add/Change/Delete Outcomes 
command in the Enter Subject Outcomes choice in the Class Info menu. 

After Subject Outcomes have been entered, they can be viewed by choosing View Subject Outcomes in 
the View menu. You can also view the outcomes by right clicking the mouse in row A in the outcomes 
columns where the student grades will be entered. 

Enter Outcomes Info 

The number representing the outcome is entered in row A in the appropriate outcome column. If the 
subject outcomes have been entered, then the outcomes and their corresponding number can be viewed 
by right clicking the mouse in row A of the outcome column. A popup menu will appear with the list of 
outcomes. You can select the outcome number to be shown in the cell by left clicking the appropriate 
choice in the menu. Each outcome number can only be entered once for each term.  

Other information for the outcome that should be entered are: 

• the term for the outcome;  

• the date the outcome is evaluated.  

A final grade for the end of the terms or year can also entered by selecting Final Grade from the drop 
down menu in the Term row of the outcome column. A grade for the subject itself can also be entered by 
entering an outcome number of 0. Only those outcomes for which grades will be given should be entered 
for the term. You should not leave any blank columns of outcome numbers without grades. Enter 
only those outcomes that are evaluated for each term. 
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An outcome code for each student is entered for each outcome evaluated during a term. See entering 
student outcomes scores for information on recording student grades for outcomes. 
 
To add additional outcome columns, use the Add New Outcome Column command in the Class Info 
Menu or the Add Outcome Columns in the Toolbar. To delete an outcome column, use the Delete 
Outcome Column command in the Class Info menu. 

Entering Student Outcome Scores 

Student scores in the outcome report cards are not kept for individual assignments. Rather, the code 
representing the achievement for a particular outcome is entered. The possible codes are setup though 
the Enter Outcome Codes in the Class Info menu. 

Students can receive one score for each outcome for each term. If an outcome is not taught during a 
term, that outcome can be left out for that term, or the outcome can be included and a code entered that 
indicates the outcome wasn't taught that term. The code entered for each student for each outcome must 
correspond to one of the outcome codes entered using the Enter Outcome Codes command.  

A student score can also be entered for the Subject itself in the Subject Grade column.  

Student scores can be entered directly into the cells of the worksheet. Scores can also be entered by 
right clicking on a student cell in the outcome column, then using the Enter Outcome Code command to 
enter scores for individual students or the Repeat Outcome Code to enter the same code for that 
outcome for all students. 

Outcomes Gradebook Tools Menu 

These tasks can be found in the Tools menu of the Outcomes Gradebook. 
 
Export Grades: See Exporting Grades 

Copy Students: This command allows the user to copy students from one class to another in the 
gradebook. 

Copy Class Comments: This command allows the user to copy Class Comments from one class to 
another in the grade book. 

Copy Grading Info: This command allows the user to copy term info, outcomes codes and subject 
outcomes from one class to another in the grade book. 

Create New Gradebook: This command is used to create a gradebook for a new semester or trimester in 
the same year or to begin a new year. Grading Information and/or student lists can be copied to the new 
gradebook. The Create New Gradebook wizard guides the use through the process of creating the new 
gradebook. 

Set Password: This command will allow the user to set a password to restrict access to the gradebook. 

Protect\Unprotect Sheet: Sheets should only be unprotected if data is inadvertently written to a 
protected cell and needs to be corrected. 

Reset Outcomes Menu: This command can be used if error messages occur when attempting to 
execute menu commands. Resetting the outcomes menu will frequently eliminate the problems causing 
the error messages. 
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Program Menus 

File Menu 

The File menu for Class Administrator is a modified version of the normal Excel File menu. Some of the 
menu choices that are not needed with the Class Administrator program have been deleted. The menu 
choices in Class Administrator do the same actions as the normal Excel File menu choices. 
 
The menu choices in Class Administrator allow you to open, save and print gradebooks. New gradebooks 
must be created from the Create New Gradebook choice in the Tools menu or by opening the 
ClassAdmin.xlt file template. 
 

Edit Menu 

The Edit menu for Class Administrator is a modified version of the normal Excel Edit menu. Some of the 
menu choices that are not needed with the Class Administrator program have been deleted. The included 
menu choices in Class Administrator do the same actions as the normal Excel Edit menu choices. 
 
The menu choices in Class Administrator allow you to cut, copy and paste information. You can also use 
the Fill choice to copy information from one cell to a group of cells immediately below, above, left or right 
of the selected cell. You can also move or copy a class worksheet from one gradebook to another with 
the Move or Copy command. It is also possible to Find or Replace text in the class worksheet. 

View Menu 

The View menu for Class Administrator is a specially designed menu allowing the user to view information 
that is normally hidden from view so as to conserve space. The following information can be viewed.  

• Student Information Columns: Show the columns with the phone number and parent names for 
each student.  

• Class Comments: Show the class comments list used to enter codes for individual student 
comments. Class comments can be imported from the School Administrator program or entered 
manually. See Enter Class Comments for more information on this topic.  

• Student Comments Columns: Show the columns that are used to enter and display the comments 
codes for individual students.  

Custom Codes Columns(Letter/Percentage gradebooks only): If your school uses the custom code 
information in the School Administrator program or in the Report Card workbook template, this command 
will show the columns used to enter and display that information. 

Format Menu 

The Format menu for Class Administrator is a modified version of the normal Excel Format menu. Some 
of the menu choices that are not needed with the Class Administrator program have been deleted. The 
included menu choices in Class Administrator do the same actions as the normal Excel Format menu 
choices.  

• The Sheet command includes options to Rename or Hide|Unhide Sheets. This command is 
useful if an error message is displayed when attempting to show a report. This would occur if a 
previous report sheet had not been deleted after viewing. (Report sheets should automatically be 
deleted when the report is closed.) If an error message occurs when attempting to show a report, 
go to the Sheet command and click the Unhide selection. Unhide any report sheets listed and 
delete them by right clicking on the report worksheet tab at the bottom of the screen, then select 
delete from the pop up menu.  
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• The Sort Students command will sort the student names in ascending or descending order.  

• The Sort Assignments or Sort Outcomes command will sort the assignments or outcomes by date 
or term in ascending or descending order.  

• The Format Cells command allows the user to change the cell's font type and style, alignment, 
border and value type. The value type identifies the type of information that is represented by the 
cell's value. For example, each column headed by the % symbol should have a value expressed 
as a percentage. If any of those cells show a decimal value, the user can change the value to a 
percentage through the Format Cells|Value Type command.  

• The Row Height and Column Width adjusts the sizes of the rows and columns, respectively.  

• The Format Row command will reset the default row colors. 
 

Reports Menu 
 
Letter/Percentage Gradebook Reports  

• Student Single Class Summary - This report will summarize information for individual students for 
one class. Information that can be included are term grades, final grade, comments, grade scale, 
assignment scores and missing assignments. You can publish the Single Class Progress Reports 
to your school's online web site for parents to view if you have an account with the EduK12 
Online Community.  

• Student Multi Class Summary - This report will summarize each student's grades for all of the 
classes in the gradebook in which the student is enrolled. Progress reports can be generated 
from multiple gradebooks by opening all of the desired gradebooks at the same time. The report 
will search each gradebook for the grade information for each student in the selected reference 
class. The gradebooks will need to be stored in a common shared folder on a server to be able to 
access and open them. Information that can be included with this report are term and final 
grades, comments, grade scale and missing assignments. You can publish the Multi Class 
Progress Reports to your school's online web site for parents to view if you have an account with 
the EduK12 Online Community.  

• Class Summary - This report summarizes all student grades for a class. Information that can be 
included are student term and final grades, grade scale, grade distribution, class mean, class 
median and class standard deviation.  

• Assignment Summary - This report summarizes student scores for a chosen assignment for the 
active class. The active class is the worksheet that is currently shown. Information that can be 
included are all student scores, those students missing the assignment, grade scale, assignment 
mean and median, assignment high score and low score.  

• Missing Assignments - This report shows missing assignments for all students for a class. 
Missing assignments in each report are determined by a blank student score and an assignment 
date earlier than or equal to the report's date. 

Outcome Gradebook Reports  

• Student Single Class Summary - This report will summarize information for individual students for 
one class. Information that ca be included are the term grades, comments and outcome codes. 
You can publish the Single Class Progress Reports to your school's online web site for parents to 
view if you have an account with the EduK12 Online Community.  

• Student Multi Class Summary - This report will summarize each student's grades for all of the 
classes in the gradebook in which the student is enrolled. Progress reports can be generated 
from multiple gradebooks by opening all of the desired gradebooks at the same time. The report 
will search each gradebook for the grade information for each student in the selected reference 
class. The gradebooks will need to be stored in a common shared folder on a server to be able to 
access and open them. Information that can be included with this report are term grades, 
comments and outcome codes. You can publish the Multi Class Progress Reports to your 
school's online web site for parents to view if you have an account with the EduK12 Online 
Community. 
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Troubleshooting Problems 

Problem: Executing a command in the View menu generates an error. 
Solution: Most of the time, these errors can be resolved by doing the Reset Gradebook Menu or Reset 
Outcomes Menu  command in the Tools Menu.  

Problem: No terms show up in the View Terms drop down menu. 
Solution: Run the Reset Gradebook Menu or Reset Outcomes Menu command in the Tools Menu. 

Problem: There appears to be an error in the calculated term and final grades. 
Solution: Run the Recalculate Grades command in the Tools menu. 

Problem: An error occurs when attempting to generate a report. 
Solution: Go to the Sheet command in the Format menu. If the Unhide command is enabled, click it. 
Choose any report sheets that are hidden and unhide them one at a time. Right click on the Sheet's tab at 
the bottom of the page, then delete the sheet. 

Technical Support 

Go to Customer Support Online at http://www.educonnect.com/support/CustomerCenter and view FAQs 
and the Knowledge Base 

Email: techsupport@educonnnect.com 

Phone: 913-384-6701 


